Eidos Forums  

Go Back   Eidos Forums > Current Games > Mini Ninjas > Mini Ninjas Tech Issues

Notices

Reply
 
Thread Tools Display Modes
  #1  
Old 09-12-2009, 10:28 AM
Prophet Prophet is offline
New Player
 
Join Date: Sep 2009
Posts: 1
Exclamation Mini Ninja's Mini LAG!! ****Patch this Eidos******

Eidos.....patch this issue already!!

As posted in another, thread this game, for about every about 4 seconds, does a Mini lag for about half a second CONSTANTLY!!....

People are stating that by unplugging certain keyboards or other HID (USB) devices, the lag then goes away....I don't want to have to get behind my desk to move it away from the wall just to get to the back of my PC to plug and unplug every time I want to play this game!!...It looks like a fun game but damn it PATCH this issue that people are seeing already!!
Reply With Quote
  #2  
Old 09-12-2009, 12:14 PM
JimProfit JimProfit is offline
New Player
 
Join Date: Sep 2009
Location: Norge
Posts: 21
Default

Yeah, I unplug everything except the controller when I play the game. So instead of looking forward to playing it again, I'm putting if off and dreading it. Haha. THIS IS NOT HOW IT'S SUPPOSED TO BE.

And again this issue has been around and known since Kane & Lynch and it's still blowing my mind they haven't gotten rid of it yet. DO YOUR JOB, PEOPLE.
Reply With Quote
  #3  
Old 09-12-2009, 01:51 PM
SadNinja SadNinja is offline
New Player
 
Join Date: Sep 2009
Posts: 1
Default

Im having some of the same issues as everyone else except my game totally freezes up and i have to reboot manualy.

Sure would be nice to hear from the devs or forums mods to atleast know they are planning on working towards some solutions. Doesnt install a whole lot of confidence to the consumer to not hear a peep out of anyone. Hope i didnt throw my money out the window.
Reply With Quote
  #4  
Old 09-12-2009, 03:06 PM
IonAphis IonAphis is offline
New Player
 
Join Date: Sep 2009
Posts: 9
Default

Registered only to post here.
I, as well have the problem. I have a Microsoft Wireless Desktop (Mouse and Keyboard) and a Logitech RumblePad 2 Wireless. All wireless and all USB connected. No other keyboards or mouses, so if I unplug everything I can't play!

By the way i have a Intel Core 2 Quad Q6600, 5 Gb of RAM, ASUS P5W DH Deluxe and GeForce 9600 GT.... by far I shouldn't have to face any studder/lag every 4 seconds.

By the way, I noticed in the options menu, where it says "Use Controller", it's says On (or Yes, I don't remember now), but it's greyed out and I can't turn controller Off. Someone on another post said they thought the game studdered because it was looking for connected controllers and couldn't find any and as a result it would do that lag thing. If I could turn the "Use Controller" Off, that might help? But it's greyed out so... I'm kind of lost now... Eidos, please solve this...
Aphis
Reply With Quote
  #5  
Old 09-14-2009, 02:03 PM
IonAphis IonAphis is offline
New Player
 
Join Date: Sep 2009
Posts: 9
Default

Great news, I got it fixed. While looking around the internet alot of people stated that you could just disable the devices that were giving conflict and all would be gone. Well, I use a wireless desktop system (mouse and keyboard) and that wasn't an option. But i found something kind of interesting. When turning off HID Non-User Input Data Filter (KB 911895), the problem disappeared. I did not have to turn off any other HID devices or disconnect anything. Just go to Device Manager -> Human Interface Devices and turn off the data filters.
Apparently, this fix is intended to fix issues of multimedia keyboards and devices to keep the connection to the OS. It sort of keeps on establishing a connection in order to give full support for the keys in your keyboard and mouse. Mind you, turning these off means you'll not be able to actually use the "special" keys on your keyboard and specially assigned functions to either mouse and keyboard (assuming they are USB connected). Once you're done playing, just go back to the Device Manager and turn them back on. I realize this is not a solution, but until Eidos does something about it, it should work (and without having to go behind your PC and physically unplugging things).
Not sure it will work for everyone, but I think this is the most probable culprit.
Happy gaming,
Aphis
Reply With Quote
  #6  
Old 09-21-2009, 12:20 AM
wand44 wand44 is offline
New Player
 
Join Date: Sep 2009
Posts: 1
Default

@IonAphis- I cannot find that under Human Interface devices....I have a bunch of other stuff...not that...

I too have a bluetooth keyboard mouse bundle and cant replace any1 either.. pls help
Reply With Quote
  #7  
Old 11-25-2009, 09:15 AM
alu21 alu21 is offline
New Player
 
Join Date: Nov 2009
Posts: 1
Default

Same problem.
Need a patch right now.
HELP.
Reply With Quote
  #8  
Old 12-09-2009, 09:20 PM
swks26 swks26 is offline
New Player
 
Join Date: Dec 2009
Posts: 1
Default

Sigh never knew that this game has a bug with USB devices. Please patch!
Just bought the game only to find out that I lag every 4seconds..
Reply With Quote
  #9  
Old 02-06-2010, 01:38 AM
user82 user82 is offline
New Player
 
Join Date: Feb 2010
Posts: 1
Default

There is probably an easy fix:

http://support.microsoft.com/default...1272#appliesto

with this small microsoft command line tool you should be able to make a .bat like this:

devcon disable <device1 that causes lag>
devcon disable <device2 that causes lag>
.......
start "C:\Program Files (x86)\Eidos\Mini Ninjas\ninja.exe"

devcon enable <device1 that causes lag>
devcon enable <device2 that causes lag>
.....


i am testing it right now
Reply With Quote
  #10  
Old 02-22-2010, 07:37 AM
kid kid is offline
New Player
 
Join Date: Feb 2010
Posts: 1
Default

Quote:
Originally Posted by user82 View Post
There is probably an easy fix:

http://support.microsoft.com/default...1272#appliesto

with this small microsoft command line tool you should be able to make a .bat like this:

devcon disable <device1 that causes lag>
devcon disable <device2 that causes lag>
.......
start "C:\Program Files (x86)\Eidos\Mini Ninjas\ninja.exe"

devcon enable <device1 that causes lag>
devcon enable <device2 that causes lag>
.....


i am testing it right now
Yeah, I did it too, testing the devices to know which ones are the origin of the lag and making a bat. I had a problem with the "start" command because it needs more options, I mean, I did it this:
Code:
start /WAIT "Minininjas" "%ProgramFiles%\Eidos\Mini Ninjas\ninja.exe"
The "/WAIT" option is for the batch file to wait until the game is closed and avoid to enable the devices before.
This is the way that works for me.
Reply With Quote
  #11  
Old 11-01-2011, 11:16 PM
luftek luftek is offline
Registered User
 
Join Date: Nov 2011
Posts: 1
Default

Quote:
Originally Posted by kid View Post
The "/WAIT" option is for the batch file to wait until the game is closed and avoid to enable the devices before.
This is the way that works for me.
Splendid suggestion, man, i tried it as well. Really works fine!

Last edited by luftek; 06-18-2012 at 11:47 PM.
Reply With Quote
  #12  
Old 08-30-2012, 06:43 AM
soundcreepy soundcreepy is offline
New Player
 
Join Date: Aug 2012
Posts: 2
Default

So, for that .bat file to work, do you enter in hardware IDs for each device in question? I have 3, was able to discover them using device manager, but if I could figure out how to do the .bat file, that would be killer.

Been using PC's since I was 3, but still can't program worth dung.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 08:03 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.