Results 1 to 12 of 12

Thread: Deus Ex Sound Problems

  1. #1
    Hoffgod Guest

    Default Deus Ex Sound Problems

    I'm having a rather weird problem with my copy of Deus Ex: GOTY. Whenever anyone says something, the game will only play about half of the message before skipping to the next message.
    I'm running this on a Dell Latitude D810 laptop. 1.73 ghtz Pentium M processor, 512 MB RAM, ATI Mobility Radion X300 graphics card.
    Any help is appreciated. I got started on Invisible War before I got GOTY, and now I really want to beat this before resuming Invisible War.

  2. #2
    Join Date
    Dec 2004
    Location
    Crayon Box
    Posts
    1,401

    Default

    I've sort of had that kind of problem but in a different way. When I click to skip a message I've already heard later in the game sometimes the character sound will go away in little talking scenes.

    Hope someone gives you the help you need.. Good luck.

  3. #3
    machinima Guest

    Default

    Hi there...I have a similar system (Dell Inspiron 8600, ATI Radeon Mobility 9600 Pro Turbo, 768MB of RAM, Pentium M 755), and am experiencing exactly the same problem with my copy of GOTY. I know this thread is old, but it's very frustrating - can anyone lend a hand? Hoffgod, did you have any luck?

  4. #4
    Join Date
    Feb 2006
    Location
    Behind you
    Posts
    322

    Default

    I had that same problem, but only after I pressed skip message so many times that it just kept skipping by itself. It's probably something to do with your sound card, but it this case it may be something to do with your video card as well. Have you tried downloading patch v1.2? Do that. If it doesn't work after that, tell me what kind of sound card you have.

  5. #5
    Join Date
    Dec 2004
    Location
    Crayon Box
    Posts
    1,401

    Default

    Quote Originally Posted by AlexDenton
    I had that same problem, but only after I pressed skip message so many times that it just kept skipping by itself. It's probably something to do with your sound card, but it this case it may be something to do with your video card as well. Have you tried downloading patch v1.2? Do that. If it doesn't work after that, tell me what kind of sound card you have.

    Yes, my problem is like that. I was running this on an old Mac at the time so maybe that was why.

  6. #6
    Join Date
    Feb 2006
    Location
    Behind you
    Posts
    322

    Default

    Are you not having the problem anymore?

  7. #7
    Join Date
    Dec 2004
    Location
    Crayon Box
    Posts
    1,401

    Default

    Who me? I haven't played DX in a very long time.

  8. #8
    Join Date
    Feb 2006
    Location
    Behind you
    Posts
    322

  9. #9
    Join Date
    Sep 2006
    Posts
    1

    Default

    Note: This post is about Deus Ex: GOTY.

    I have the same problem as "Hoffgod". I found a workaround, but maybe someone that knows more will be able to expand on it.

    If I start up the game with hardware rendering, it skips half of every speech segment whether in a transmission or a cutscene/video. I also noticed that everything moves faster than normal (about 2x speed). If I switch to software rendering and then switch back to hardware rendering, the game works fine until it is restarted. The character moves at a normal speed and all the speech completes.

    I have no idea how to explain this or make the fix permanent without repeating this process every time. This is repeatable, though. START IN HARDWARE RENDERING (SOUND PROBLEM PRESENT & FAST MOTION) ->
    CHANGE RENDERING DEVICE (RESTART REQUIRED) ->
    SET RENDERING TO SOFTWARE (SOUND PROBLEM NOT PRESENT & NORMAL SPEED MOVEMENT) ->
    CHANGE RENDERING DEVICE (RESTART REQUIRED) ->
    SET RENDERING TO HARDWARE (SOUND PROBLEM NOT PRESENT & NORMAL SPEED MOVEMENT) ->
    IF RESTART, PROBLEMS RETURN

  10. #10
    Join Date
    Feb 2010
    Posts
    1

    Thumbs up Here's the fix that worked for me

    I'm using Windows 7 and using a Sound Blaster and this worked for me (using a fix that works on unreal too):

    Open your DuesEx folder, go in to system and open "deusex.ini"

    Find the section that says: [Galaxy.GalaxyAudioSubsystem]

    In that section their will be a line that says "Latency=40"
    Change it to read "Latency=60"

    Close the file (saying yes to save)

    Restart DeusEx and the sound works fine

  11. #11
    Join Date
    Sep 2010
    Posts
    1

    Default

    Dude... I signed up just to thank you for this solution. Haha...

    Know what is funny? One of the words in the captcha was "deduce", as in to work out, solve, etc. Weird.

    Thank you!

  12. #12
    Join Date
    Jun 2011
    Posts
    6

    Default

    I've installed the latest patch for Deus Ex but I can't run the game unless I disable all sound. This is the error message I get from Windows XP.
    "General protection fault!
    History: glxDetectOutput <- UGalaxyAudioSubsystem::Init <- UEngine::InitAudio <- UGameEngine::Init <- XGameEngine::Init <- DDeusExGameEngine <- InitEngine"
    Although Eidos recommends using an EAX compatible sound card no special sound requirements are listed. I use the built in sound on my computer which has built in sound on an Epox EP-3VBA2/3VCA/6VBA2 motherboard.
    Please advise!

    Promote your hair growth with
    _________________________
    argan oil
    Last edited by Alvasin; 07-27-2011 at 10:25 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •