Results 1 to 3 of 3

Thread: DXHR Director's Cut (PC) will not start

  1. #1
    Join Date
    Apr 2014
    Posts
    2

    Default DXHR Director's Cut (PC) will not start

    Good morning,

    I purchased DXHR-DC via Steam and have never been able to get it to start on my Win7 x64 PC. When I try to run it using Steam, a Steam-ish dialog box appears very briefly saying, "Preparing to run Deus Ex..." and then nothing happens. When I try to run it straight from the executable, nothing happens at all. No entries appear in the Windows Event Logs.

    Steam tech support have had me troubleshoot the Steam client, and apparently the Steam client and game install are good from their perspective. I own dozens of Steam and non-Steam games and other apps, and this is the only one I have problems with.

    I have spent the past three weeks working with Square Enix tech support, and they have run out of ideas, finally telling me to post on this forum.

    Apparently quite a few people on the Steam forums (and also on this forum) have this problem, and an oft-mentioned fix is to disable Integrated Graphics support via Device Manager. However, my Device Manager doesn't show integrated graphics hardware - only my AMD Radeon HD card.

    Hopefully you folks at Eidos can help out. I've listed below most of the troubleshooting attempts I can recall. I have DxDiag and MSInfo reports ready if you want them (this post is long enough already :P).
    Thanks in advance!

    ---------------------

    -If you are running Windows XP, please update to Windows Service Pack 3.
    n/a - running Win7 x64
    -Be sure to update to the latest version of DirectX. (NOTE: Having an updated version of DirectX 10, 11, Vista, or Win7 DOES NOT necessarily mean that your DirectX 9 is also up to date.)
    Re-ran the installer/updater for DirectX (presumably 11), also tracked down an offline installer for DirectX 9.0c and installed that as well. Still doesn't run.
    -Be sure to ensure that any anti-virus and anti-malware is set to allow the game and Steam to run with full privileges.
    I'm using Avast! - I don't see a way to restrict running privileges for any specific software, so I disabled Avast, rebooted and tried running the game (still doesn't work)
    -Try to "Validate the Integrity of your Game Cache". Select the Game inside of Steam and select properties > Local Files > Verify Integrity of Game Cache. This will ensure all game files match the latest version available on Steam
    You folks had me try this a couple of times already; it doesn't work.
    -If you are running an Alienware machine with the Alienware lighting effects option enabled, ensure that the Alienware command center is installed.
    n/a - Not using an Alienware machine
    -Be sure to ensure that other games are still able to launch, including launching other games through Steam.
    I have about two dozen Steam games installed and several non-Steam ones of all types, older and modern; Deus Ex HRDC is the only game or app that I have installed that won't run.
    -If you are using Zone alarm Security you may want to try uninstalling it, as it's been known to cause problems with the game.
    n/a - not using Zone Alarm
    -Check the RAM on the PC, ensure that none of the RAM has gone bad or is mismatched with different RAM.
    I ran a RAM checker overnight; all the RAM checks out. I'd be having problems with other games if I had bad RAM anyway.
    -Make sure that your game and drivers are fully patched, and the issue should go away.
    Video and audio are patched, and I've tried removing and reinstalling Deus Ex HRDC from Steam to ensure it's up to date. It still won't run.
    -If you have already updated drivers, try temporarily disabling the In-Game Steam Overlay to see if the problem persists. This can be done from the Steam Library by right-clicking the game > Properties > General Tab
    > Uncheck "Enable Steam Community In-Game". -Steam updates this overlay independent of our game patches, so problems eliminated by the above procedure can only be fixed by Steam UI updates and patches.
    Unchecked this and tried again; the game still won't run.
    -If your video card does not support DirectX 11. Please ensure that this feature is disabled within the game.
    n/a - my video card supports DX11.
    -Try setting up a Steam Library on your boot drive and running from there
    Tried this, still does not run
    -Ensure you have full admin rights to your PC, in particular to the location where your game is installed
    I do have full admin rights to this machine
    -We would like for you to disable all non OS essential processes on your system temporarily using msconfig > Disable All. Once this is completed select apply and then restart your system. Specifically we would like for you to make sure you have temporarily disabled any processes related to anti-virus or firewalls for testing purposes.
    Did this, game will still not run, including disabling my virus scanner. I don't run a PC-based firewall.
    - Try running in WinXP SP2/SP3 Compatability Mode
    Still doesn't work

  2. #2
    Join Date
    Jul 2014
    Posts
    2

    Default

    d_reid: Do you have more than 24 cores? I am about to post about the game failing to start in Steam due to having more than 24 cores. Just a thought.

  3. #3
    Join Date
    Apr 2014
    Posts
    2

    Default

    No, I have a single 4-core processor: an AMD Phenom II X4 965.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •