Page 42 of 44 FirstFirst ... 32333435363738394041424344 LastLast
Results 1,026 to 1,050 of 1094

Thread: STUTTERING & LAG / FRAME RATE Drop - Video & Audio - All Discussion

  1. #1026
    Join Date
    Mar 2012
    Posts
    1

    Default

    Hi, i own the game this week and i come here because im having this stuttering problem too and this just broken the pleasure to play the game. I read and tried some steps posted here and in anothers forums but it dont make diferrence.

  2. #1027
    Join Date
    Dec 2007
    Location
    Under the leaves...
    Posts
    21,987

    Default

    Welcome.
    If you have tried all the suggestions found in the sticky threads above, then your only option is to contact official support :

    I would like to assure you all that representatives of Eidos Montreal, Nixxes, as well as Square Enix, are closely monitoring these forums to look for any issues that users are running into and that require attention. Please note however that this is not an official support mechanism, and if you require official support we recommend you contact http://support.eu.square-enix.com/ for Europe or http://support.na.square-enix.com for America.
    signature image
    You are only minimally modified. Omar can help you correct this...

  3. #1028
    Join Date
    Dec 2011
    Posts
    52

    Default

    Ok this is just getting silly.
    As much as i appreciate the help your doing here viktoria,your kinda beating a dead horse with your cookie cutter responses.
    Many of us here have tryed to solve this issue,but it was pretty evident that its the software at fault.It needs to be fixed by eidos/nixxes and only them.Stop trying to pin the problems on the user-end....because thats NOT whats at fault here.Its the game!

    I myself am pretty tech savvy when it comes to pc's,and have been building them for 10+ years,but i find it very frustrating to be told to do this or that with my system when i know damn well thats not the problem here.

    The online petition has once again risen in numbers,and new people who just brought the game,are getting told to contact support! The support site is worthless,so dont waste your time.Its been proven over and over again that the game is broken,not our systems.

    I will be telephoning the eidos uk offices today,and complaining about the crappy support in general for this game.Also,the uk trading standards are watching very closely and monitoring these forums as i have an open case for a refund due to faulty software.News sites are gonna lap this one up!

  4. #1029
    Join Date
    Dec 2007
    Location
    Under the leaves...
    Posts
    21,987

    Default

    I'm here to help those who haven't yet "tried everything".
    As you say that you already have, then you can simply ignore my posts.
    signature image
    You are only minimally modified. Omar can help you correct this...

  5. #1030
    Join Date
    Oct 2011
    Posts
    3

    Default

    I have already tried everything to fix the stuttering, but I'm pretty sure that it was pointless. This is clearly a software problem, made worse by the last patch. Version 1.2.633.0 and The Missing Link run great on my hardware (single core CPU!), no stuttering at all, and the base game is unplayable since the 643 patch. Someone at least needs to review the changes between the patches and the DLC. Please, just admit that this is not an end user problem.

  6. #1031
    Join Date
    Nov 2010
    Posts
    43

    Default

    Any comment at all would be nice. Sadly it'll probably take alot of angry calls and emails to get their attention, as well as contacting game news sites to get this message out there. I really just think they don't care about their game anymore. It's sad.

  7. #1032
    Join Date
    Nov 2010
    Posts
    98

    Default

    I don't care what any forum moderator says or posts. I don't care what Eidos or Nixxes says. None of them give a damn about the game or customers or they would still be making patches.

  8. #1033
    Join Date
    Dec 2011
    Posts
    52

    Default

    My theory,is that nixxes asked for more funding to get the team in and patch the game up....but eidos refused.

    Eidos montreal mainly dealt with the console versions,and as far as they're concerned they done their part and got our hard earned cash.Nixxes on the other hand are fully responsible for this craptastic pc port....you know...the company who are supposedly god-like at porting pc games.(according to eidos)

    Anyways,I agree with you completely Dragonknight.If this is the standard of deus ex's future pc outtings...then don't bother making a pc port...in-house or not.Obviously the console market was their main target,considering they outsourced the pc version of a prequel to the greatest pc game of all time.....pathetic.

  9. #1034
    Join Date
    Mar 2012
    Posts
    1

    Thumbs down

    The game is totally unplayable, it stutters from the very beginning. Man, it's bad.

  10. #1035
    Join Date
    Nov 2010
    Posts
    43

    Default

    Glad I'm not the only one! I was worried my cards were the problem!

  11. #1036
    Join Date
    Jul 2010
    Posts
    184

    Default

    I had some issues with frame skipping after the latest patch which I could resolve by installing the at that time current NVidia driver.
    Unfortunately the frame skipping seems to have returned with one of the later drivers, but I don't really feel like checking out old driver versions again, so yeah...

    Anyway, if anyone is desperate enough, maybe that might help someone.

    Aunt EDITh says:
    I fiddled around a bit, finaly disabling vsync and triple buffering in game, and using the NVidia driver control panel to enable vsync and triple buffering for the dxhr.exe there (in b4 some discussion about whether TB on the driver level works in Direct3D games or only in OpenGL).
    Anyway, my frame-skipping issues seem to be much better now, form very noticeable before it's now practically gone again.
    Will observe the issue a bit, though, one never knows...


    Ok, upon further inspection, I don't know what's causing the stuttering.
    Sometimes it stutters, sometimes the game is butter-smooth.
    Might be related to restarting it, might be related to me fiddling around with different settings for vsync and tripple buffering (in game and on the driver level).
    Whatever the reason, it worked fine before the last patch, then seemed to be fixed by a certain NVidia driver version and can be very bad right now, unless I'm lucky and it works for a session.
    Strange...
    Last edited by El Zoido; 03-28-2012 at 02:55 PM.

  12. #1037
    Join Date
    Aug 2011
    Posts
    14

    Default

    Quote Originally Posted by deemonize View Post
    Ok this is just getting silly.
    As much as i appreciate the help your doing here viktoria,your kinda beating a dead horse with your cookie cutter responses.
    Many of us here have tryed to solve this issue,but it was pretty evident that its the software at fault.It needs to be fixed by eidos/nixxes and only them.Stop trying to pin the problems on the user-end....because thats NOT whats at fault here.Its the game!

    I myself am pretty tech savvy when it comes to pc's,and have been building them for 10+ years,but i find it very frustrating to be told to do this or that with my system when i know damn well thats not the problem here.

    The online petition has once again risen in numbers,and new people who just brought the game,are getting told to contact support! The support site is worthless,so dont waste your time.Its been proven over and over again that the game is broken,not our systems.

    I will be telephoning the eidos uk offices today,and complaining about the crappy support in general for this game.Also,the uk trading standards are watching very closely and monitoring these forums as i have an open case for a refund due to faulty software.News sites are gonna lap this one up!
    +1

  13. #1038
    Join Date
    Feb 2012
    Posts
    11

    Default

    Haven't been on here for a while but I am pleased to say I finally fixed my game and I can now play it relatively stutter free at max DX11 settings. Here's how I sorted it -

    - install latest drivers
    - use MSI Afterburner framerate limiter and set to 60fps, this has to be running in the background
    - click play button on Steam for the game and select "Setup Deus Ex:Human Revolution" option.
    - click "set to default" option, then ok
    - click play button on Steam for the game and select "Play Deus Ex:Human Revolution"option which takes you into the game.
    - Now select all your graphic options that you want (I play max DX11) but make sure to select the vsync and triple buffering option
    - Load your save or start a new game wherever you are at


    I have to carry out that same process in bold blue writing everytime I play the game to have a stutter free experience (Only tiny little saving stutters are apparent which is perfectly normal with mechanical HDDs). If I don't carry that procedure out it will have GPU usage issues, frameskipping the whole works. I genuinely feel there may be a problem with the startup initialisation of the game and for some people, like myself. it is not hooking correctly.

    I'm now able to fully get lost in the Deus Ex world and enjoy the game....it's awesome!!

    It also works the same way for the missing link DLC too. Hope that helps someone.
    Last edited by LifeonMars; 04-10-2012 at 11:53 AM.

  14. #1039
    Join Date
    Apr 2012
    Posts
    38

    Default

    Hi everyone, I came to this forum to ask tech questions about video stuttering......looks like I came to the right place.

  15. #1040
    Join Date
    Feb 2012
    Posts
    6

    Default

    Not sure if it's the latest AMD 12.3 driver or it has been some patch but the stuttering got better on my machine.

    I even play now Deus Ex in stereoscopic 3D via AMD HD3D on my new Acer polyfilter 3D monitor and it's fluid in most places. I went back to the places where the stuttering was very strong (like Detroit) and it got better but it's still there.

  16. #1041
    Join Date
    Dec 2007
    Location
    Under the leaves...
    Posts
    21,987

    Default

    Quote Originally Posted by LifeonMars View Post
    Haven't been on here for a while but I am pleased to say I finally fixed my game and I can now play it relatively stutter free at max DX11 settings. Here's how I sorted it -

    - install latest drivers
    - use MSI Afterburner framerate limiter and set to 60fps, this has to be running in the background
    - click play button on Steam for the game and select "Setup Deus Ex:Human Revolution" option.
    - click "set to default" option, then ok
    - click play button on Steam for the game and select "Play Deus Ex:Human Revolution"option which takes you into the game.
    - Now select all your graphic options that you want (I play max DX11) but make sure to select the vsync and triple buffering option
    - Load your save or start a new game wherever you are at


    I have to carry out that same process in bold blue writing everytime I play the game to have a stutter free experience (Only tiny little saving stutters are apparent which is perfectly normal with mechanical HDDs). If I don't carry that procedure out it will have GPU usage issues, frameskipping the whole works. I genuinely feel there may be a problem with the startup initialisation of the game and for some people, like myself. it is not hooking correctly.

    I'm now able to fully get lost in the Deus Ex world and enjoy the game....it's awesome!!

    It also works the same way for the missing link DLC too. Hope that helps someone.

    Thanks for getting back to us. I've added it to updates on first page for easy reference, hopefully this will work for others.
    signature image
    You are only minimally modified. Omar can help you correct this...

  17. #1042
    Join Date
    Nov 2010
    Posts
    98

    Default

    How about Eidos and Nixxes actually make some more patches? It's clear they don't care about the customers or the game, and don't bother saying they care when their actions show otherwise.

  18. #1043
    Join Date
    Apr 2012
    Posts
    2

    Exclamation

    Quote Originally Posted by LifeonMars View Post
    Haven't been on here for a while but I am pleased to say I finally fixed my game and I can now play it relatively stutter free at max DX11 settings. Here's how I sorted it -

    - install latest drivers
    - use MSI Afterburner framerate limiter and set to 60fps, this has to be running in the background
    - click play button on Steam for the game and select "Setup Deus Ex:Human Revolution" option.
    - click "set to default" option, then ok
    - click play button on Steam for the game and select "Play Deus Ex:Human Revolution"option which takes you into the game.
    - Now select all your graphic options that you want (I play max DX11) but make sure to select the vsync and triple buffering option
    - Load your save or start a new game wherever you are at


    I have to carry out that same process in bold blue writing everytime I play the game to have a stutter free experience (Only tiny little saving stutters are apparent which is perfectly normal with mechanical HDDs). If I don't carry that procedure out it will have GPU usage issues, frameskipping the whole works. I genuinely feel there may be a problem with the startup initialisation of the game and for some people, like myself. it is not hooking correctly.

    I'm now able to fully get lost in the Deus Ex world and enjoy the game....it's awesome!!

    It also works the same way for the missing link DLC too. Hope that helps someone.
    *** A!

    I've tried all other fixes in the original post except for the two above yours, none of which worked.

    Now after a short test on the highest settings in an area with unquestionable stuttering even on modest settings...

    No stuttering!

    Here's some more details:

    1 ) Download the latest MSI Afterburner BETA from here:
    http://event.msi.com/vga/afterburner/download.htm

    2) Extract, install.

    3) Run Afterburner.

    4) Click Settings, then the Monitor tab.

    5) In the list "Active hardware monitoring graphs" scroll down to Framerate and click the gray icon to the left of the text. Now some grayed out settings beneath will activate and you should tick the boxes left of "Show in On-Screen Display" and "Show in tray icon". Now press OK.

    6) Look in your tray (bottom right of your entire monitor screen, to the left of your Windows clock) and find the MSI On-Screen Display icon. Press it once to open the program up.

    7) Click the + and locate dxhr.exe (the .exe file that you use to run the game... not a shortcut to it!).

    8) Click the large wrench icon under "General properties."

    9) Under "Framerate limiter properties" input 60 to the right of "Framerate limit", then press OK.

    10) Minimize the MSI On-Screen Display program and MSI afterburner to the tray...

    And enjoy. Please get back here if it works! I registered here just to say it works.

    Some more settings that you might want to look at in the MSI On-Screen Display I guess are (under general properties) "Start with Windows", "Show On-Screen Display" (deactivate this to remove the pink text), "On-Screen Display zoom" and "On-screen Display palette" to change the size and colour of the framerate text and colour.

    When running the game with the On-Screen Display activated the FPS should be around 60 FPS in-game I think...

    However... after some very short testing it seems the game runs fine even with no framerate limit while running MSI Afterburner and the MSI On-Screen Display in the tray... for this I have no f**king explanation lol! Perhaps just adding dxhr.exe to the OSD-program fixes stuff for some reason? I'll have to look more into this because it seems wierd.

  19. #1044
    Join Date
    Apr 2012
    Posts
    2

    Default

    Hm yeah... now all problems are gone for me even with MSI Afterburner and OSD not running at all it seems...

    Can't explain, can't complain.

    Full settings, played through the intro and not even in the areas with fire everywhere did I notice any stuttering besides what's normal lag for a graphics intensive game.

    I'm even playing the game with V-sync activate IN the game... which normally would cause a serious amount of stuttering.

    Computers, right? \_(ツ)_/ Hope it works for y'all.

    Gonna restart, get some snacks and immerse into this game now after a mere two and a half hours work.

  20. #1045
    Join Date
    Jul 2010
    Posts
    184

    Default

    Quote Originally Posted by Korhal View Post
    Hm yeah... now all problems are gone for me even with MSI Afterburner and OSD not running at all it seems...
    The stuttering is very erratic for me.
    It can be terribad and unbearable, barely noticeable or smooth as silk.
    All without changing anything on my pc or the settings.

    If there's any rule behind it I can't find it. What I do atm. is simply restarting the game until it works well enough to enjoy it.

  21. #1046
    Join Date
    Feb 2012
    Posts
    8

    Default

    Quote Originally Posted by El Zoido View Post
    The stuttering is very erratic for me.
    It can be terribad and unbearable, barely noticeable or smooth as silk.
    All without changing anything on my pc or the settings.

    If there's any rule behind it I can't find it. What I do atm. is simply restarting the game until it works well enough to enjoy it.
    I've noticed the same, strange.

  22. #1047
    Join Date
    Feb 2011
    Posts
    41

    Default

    Every time I think I've found a "fix" it turns out it wasn't really a fix. So don't post a fix unless you're absolutely sure it works.

  23. #1048
    Join Date
    Feb 2012
    Posts
    8

    Default

    Quote Originally Posted by pnoozi View Post
    Every time I think I've found a "fix" it turns out it wasn't really a fix. So don't post a fix unless you're absolutely sure it works.
    The truth is that there is no fix unless Deus Ex devs fix the issue. Sad really, the game is great but Eidos does not seem to care about these issues.
    Last edited by MrMicroship; 04-20-2012 at 06:28 AM.

  24. #1049
    Join Date
    Aug 2011
    Posts
    30

    Default

    Quote Originally Posted by MrMicroship View Post
    The truth is that there is no fix unless Deus Ex devs fix the issue. Sad really, the game is great but Eidos does not care about these issues.
    well then Eidos can off if they think i'm buying any more of thier crap

  25. #1050
    Join Date
    Sep 2011
    Posts
    77

    Default

    This might fix it. It fixed my studdering in Age of Empires 3 and The Witcher.

    For nvidia users, download the nvidia inspector program if you haven't already.

    There should be a profole for Deus Ex: Human Revolution.

    Set Triple Buffering to On
    Set V-Sync to On
    And here's what might do it:
    Set the frame rate limiter to 60fps.

    This removed my stutter/frame skipping in the first two games I mentioned and might also work for this game.

    For anyone that doesn't have a fix, try this out and see if it works.
    Last edited by Herbert Dashwood; 04-20-2012 at 02:10 PM.

Page 42 of 44 FirstFirst ... 32333435363738394041424344 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •