Eidos Forums  

Go Back   Eidos Forums > Current Games > Deus Ex: Human Revolution > DX:HR Technical Forum

Notices

Reply
 
Thread Tools Display Modes
  #1  
Old 08-23-2011, 05:34 AM
Mondos Mondos is offline
New Player
 
Join Date: Aug 2011
Posts: 3
Default STUTTERING & LAG / FRAME RATE Drop - Video & Audio - All Discussion

I have been experiencing major audio stutter in the first 45min that I have played. It seems to increase when the action picks up and is present throughout. It's extremely distracting, anyone else have this problem?

Specs:
G930 Headset
Windows 7 64bit
i5 2500K @ 4.2Ghz
GTX 570
8Gb Corsair Vengeance
Gigabyte GA-Z68X-UD3H-B3


________________________________________________



MODERATOR EDITS


Official Updates/Announcements:

March 1, 2012

Quote:
Originally Posted by Coyotegrey View Post
Talked to the guys and gals in the lab and here's their response...

"This sounds like the firmware update is needed to fix drm issues. Asus also has an update available but was lost on this link at some point, we are waiting for this to be added back also."

http://support.amd.com/us/kbarticles...platforms.aspx

"It's important to note this is not DXHR specific, it's affected any game using certain drm methods."

__




Poll and Discussion Thread on general forum:

http://forums.eidosgames.com/showthread.php?t=121283

__


Some possible solutions:

Quote:
Originally Posted by Herbert Dashwood View Post
This might fix it. It fixed my studdering in Age of Empires 3 and The Witcher.

For nvidia users, download the nvidia inspector program if you haven't already.

There should be a profole for Deus Ex: Human Revolution.

Set Triple Buffering to On
Set V-Sync to On
And here's what might do it:
Set the frame rate limiter to 60fps.

This removed my stutter/frame skipping in the first two games I mentioned and might also work for this game.

For anyone that doesn't have a fix, try this out and see if it works.


Quote:

Game Laggy / Lagging or Low Performance

As with most game fixes, some that you may have used before may in fact help fix the problem you’re experiencing with Deus Ex: Human Revolution. If you have any sort of lag of stuttering, then try these solutions.

– If you have NVIDIA 3D Vision installed, then remove the driver as it commonly causes lag and performance drops!
– Using NVIDIA Control Panel for NVIDIA graphics card or ATI Catalyst Center for ATI video cards, you can dramatically increase or even fix some problems you’re experiencing. Firstly, try experimenting with VSYNC — turn V-SYNC ON if it is disabled and then try running the game. If you already have it forced on, then also try disabling it. Depending on the issue, having it enabled instead of disabled or vice-versa may be a better idea than the other. It can help bypass a frames per second / FPS limit or cap and sometimes even helps if you are experiencing blur. VSYNC can effect the refresh rate.
– Another option is to enable Triple Buffering through your GFX Card Control Panel. A program like D3DOverrider can help you enable VSYNC and Triple Buffering for NVIDIA cards.
– Lower the graphics settings, resolution, antialiasing (AA), and other effects
– Upgrade your video card drivers (they generally offer bug fixes and performance increases)

So for the exact steps to enable VSYNC, Anti-Aliasing, and Anisotropic Filtering for NVIDIA cards try:
1) Load the NVIDIA Control Panel (can be accessed in system tray generally or Control Panel)
2) Click “Performance & Quality Settings” -> “Add Profile” -> enter Deus Ex: Human Revolution
3) Click “Browse” -> select the Deus Ex exe -> check the checkbox that’s next to it in the associated application list
4) Under “Application” be sure to select the entry you just added and uncheck “Application-controlled”

For ATI video cards, just Load ATI Catalyst Control Panel and expand the 3D menu. Easy!
http://geekmontage.com/texts/game-fi...-black-screen/


Quote:
Originally Posted by pnoozi View Post
Now I'm not sure what he meant. He says 16-bit 48000Hz, but the screenshot has 24-bit 192000 highlighted.

OK never mind, I think I'm still stuttering... but I swear I wasn't before. I don't have 3D Vision installed! And changing the audio doesn't do anything.

EDIT

Disabling SSAO seems to have helped a lot!
Quote:
I started playing the HR today, and the stuttering was impacting my ability to enjoy the game. It turns out that the stuttering was caused by vsync and triple buffering. Without vsync, the screen tears like crazy, and forcing it from the ATI Control Panel didn't work for me.

I ended up using the Direct3DOverrider that comes with RuvaTuner. There's an option in the program to force vsync and triple buffering (make sure you disable it in game first). It's not compatible with every game, but it's perfect for games like Dead Space 2 with broken vsync.

The game runs as smooth as butter now. I recommend anyone still having the stuttering issue to go and download RivaTuner.
You have to use D3DOverrider. Don't force VSYNC in the control panel.
http://www.guru3d.com/index.php?page=rivatuner

In case it helps, member miseryguts recently posted this on the main DXHR forum:
Quote:
Don't know if this is going to help you but i had exactly the same issues until changed the renderer to DX11 (it defaulted to DX9 for some reason) i now have no lag or stuttering whatsoever.
Quote:
Originally Posted by MrMicroship View Post
Only fix that worked for me was MSI Afterburner and its frame rate limiter, set to 60fps. Now the game is smooth.
Nvidia 570, i2500k, Windows 7.

There is also other solution that works for some people and that is running the game in window mode.
Quote:
Originally Posted by spicyfresh View Post
I've found the holy grail. My friend directed me to this download: http://www.xtremesystems.org/forums/...=1#post5005608

ladies and gentlemen, this download completely stopped all the retarded fps lag I was having. After all this time trying to fix it this seems surreal. I have no tried watching a cutscene yet, so I don't know if the audio skipping problem persists, but ffs, at least now it's playable.

All thanks go to roidmonkey on steam for leading me to this most beautiful of downloads.

ps- he used it to fix saints row 3, so try it for every game you have that you lag on!

Quote:
Originally Posted by El Zoido View Post
I think it should be mentioned that more specifically, this is a fix for AMD Bulldozer cpus.
It's unlikely that other AMD chips will benefit from it (or even need it).


Try some of the fixes in this thread over on Steam.
http://forums.steampowered.com/forum....php?t=2075294

Quote:
Originally Posted by LifeonMars View Post
Haven't been on here for a while but I am pleased to say I finally fixed my game and I can now play it relatively stutter free at max DX11 settings. Here's how I sorted it -

- install latest drivers
- use MSI Afterburner framerate limiter and set to 60fps, this has to be running in the background
- click play button on Steam for the game and select "Setup Deus Ex:Human Revolution" option.
- click "set to default" option, then ok
- click play button on Steam for the game and select "Play Deus Ex:Human Revolution"option which takes you into the game.
- Now select all your graphic options that you want (I play max DX11) but make sure to select the vsync and triple buffering option
- Load your save or start a new game wherever you are at


I have to carry out that same process in bold blue writing everytime I play the game to have a stutter free experience (Only tiny little saving stutters are apparent which is perfectly normal with mechanical HDDs). If I don't carry that procedure out it will have GPU usage issues, frameskipping the whole works. I genuinely feel there may be a problem with the startup initialisation of the game and for some people, like myself. it is not hooking correctly.

I'm now able to fully get lost in the Deus Ex world and enjoy the game....it's awesome!!

It also works the same way for the missing link DLC too. Hope that helps someone.


Quote:
Originally Posted by Korhal View Post
*** A!

I've tried all other fixes in the original post except for the two above yours, none of which worked.

Now after a short test on the highest settings in an area with unquestionable stuttering even on modest settings...

No stuttering!

Here's some more details:

1 ) Download the latest MSI Afterburner BETA from here:
http://event.msi.com/vga/afterburner/download.htm

2) Extract, install.

3) Run Afterburner.

4) Click Settings, then the Monitor tab.

5) In the list "Active hardware monitoring graphs" scroll down to Framerate and click the gray icon to the left of the text. Now some grayed out settings beneath will activate and you should tick the boxes left of "Show in On-Screen Display" and "Show in tray icon". Now press OK.

6) Look in your tray (bottom right of your entire monitor screen, to the left of your Windows clock) and find the MSI On-Screen Display icon. Press it once to open the program up.

7) Click the + and locate dxhr.exe (the .exe file that you use to run the game... not a shortcut to it!).

8) Click the large wrench icon under "General properties."

9) Under "Framerate limiter properties" input 60 to the right of "Framerate limit", then press OK.

10) Minimize the MSI On-Screen Display program and MSI afterburner to the tray...

And enjoy. Please get back here if it works! I registered here just to say it works.

Some more settings that you might want to look at in the MSI On-Screen Display I guess are (under general properties) "Start with Windows", "Show On-Screen Display" (deactivate this to remove the pink text), "On-Screen Display zoom" and "On-screen Display palette" to change the size and colour of the framerate text and colour.

When running the game with the On-Screen Display activated the FPS should be around 60 FPS in-game I think...

However... after some very short testing it seems the game runs fine even with no framerate limit while running MSI Afterburner and the MSI On-Screen Display in the tray... for this I have no f**king explanation lol! Perhaps just adding dxhr.exe to the OSD-program fixes stuff for some reason? I'll have to look more into this because it seems wierd.



__

Quote:
Originally Posted by Nixxes View Post
I would like to assure you all that representatives of Eidos Montreal, Nixxes, as well as Square Enix, are closely monitoring these forums to look for any issues that users are running into and that require attention. Please note however that this is not an official support mechanism, and if you require official support we recommend you contact http://support.eu.square-enix.com/ for Europe or http://support.na.square-enix.com for America.

That said, we would like to give the community on this forum an update on what our near term plans are for further support for Deus Ex: Human Revolution on PC.

As you are probably aware we have already rolled out two patches soon after release to deal with issues we wanted to address as quickly as possible, after we found out that they existed. We are now looking at additional fixes for issues that some players have been experiencing, and on top of that we are also looking at adding some additional features on the PC side that we noticed some players would really like to see.

These additions are more involved as the first patches, and due to this take longer as those initial patches. We need to test them carefully to ensure we do not introduce any new issues.

Unfortunately, at this point we cannot guarantee specific fixes for patches at specific dates. Fixes once released may not always be immediately effective for every single user on every system out there. But rest assured that people at the studio, in cooperation with IHVs, are looking at all issues that come up and are trying to get them resolved for you as soon as possible.

Thank you for your patience.

__



VIDEO HELP

Preventing microstutters and sound lag in Deus Ex: Human Revolution

Some players of Deus Ex: Human Revolution, including myself, have fallen victim to a variety of game issues. Some of the more annoying issues include a tendancy to stutter, albiet only for a brief amount of time.

The other issue is sound lag, where shooting makes the sound play out seconds after the animation itself has completed.

This video shows potential fixes for both problems.


Last edited by Viktoria; 04-29-2012 at 03:52 PM. Reason: added link to main forum discussion
Reply With Quote
  #2  
Old 08-23-2011, 05:37 AM
jaycw2309's Avatar
jaycw2309 jaycw2309 is offline
Inside Man
Eidos Official
 
Join Date: Apr 1998
Location: Wimbledon
Posts: 3,667
Default

Quote:
Originally Posted by Mondos View Post
I have been experiencing major audio stutter in the first 45min that I have played. It seems to increase when the action picks up and is present throughout. It's extremely distracting, anyone else have this problem?

Specs:
G930 Headset
Windows 7 64bit
i5 2500K @ 4.2Ghz
GTX 570
8Gb Corsair Vengeance
Gigabyte GA-Z68X-UD3H-B3
You dont mention your audio chipset? is it realtek? motherboard chipset not a dedicated card etc?
__________________
http://www.imdb.com/name/nm1255523/ <-thas me hehe
Twitter: @jaywalker2309
- My opinion is my own and not that of the company.
Reply With Quote
  #3  
Old 08-23-2011, 06:03 AM
djchozen91 djchozen91 is offline
Registered User
 
Join Date: Aug 2011
Posts: 1
Default STUTTERING & LAG / FRAME RATE Drop - Video & Audio - All Discussion

Any time I access a terminal in the game, zoom into iron-sights, or switch into a third-person animation, the camera stutters. It is extremely annoying. I have the latest drivers for my nvidia GTX460. I have tried switching off dx11 mode but that actually resulted in the game not launching at all. I have tried turning each graphics option on and of and nothing changes.

I'm running:

Windows 7 Home Premium
i7 950
4gb DDR3 ram
GTX460

Would appreciate some help if anyone can lend it.
Reply With Quote
  #4  
Old 08-23-2011, 06:23 AM
Eidos Support Eidos Support is offline
Eidos Technical Support
 
Join Date: Dec 2008
Location: Square Enix Europe
Posts: 305
Default

Are you able to try your onboard sound instead of the headset and see if it makes a difference? You could also make sure you have installed the latest drivers for your headset:

http://www.logitech.com/en-gb/438/72...tion=downloads

(From UK logitech site, as that is where I am based; change to your local if need be. )
__________________
Eidos Support
Contact Support Directly:
Square Enix Support Europe
Square Enix Support North America
Reply With Quote
  #5  
Old 08-23-2011, 07:27 AM
Mondos Mondos is offline
New Player
 
Join Date: Aug 2011
Posts: 3
Default

I'm not sure what i am using since it is a usb headset. Though I don't have a sound card so I guess the usb uses on board sound?

The on-board sound for my motherboard is (Realtek ALC889 codec).

I never actually downloaded the drivers for it, so I'll try that. I'll also try using a set of audio jack earbuds and see if the stuttering goes away. Will update with results!
Reply With Quote
  #6  
Old 08-23-2011, 07:39 AM
Mondos Mondos is offline
New Player
 
Join Date: Aug 2011
Posts: 3
Default

I tested it with the on-board sound and it worked fine. When I was back there plugging in my earbuds I noticed I had my headset plugged into a usb 3.0 slot. From the 20 seconds I tested it now works fine without stutter in the usb 2.0 slot. I hope that was my problem, will update if stutter returns.

Thanks!
Reply With Quote
  #7  
Old 08-23-2011, 07:45 AM
stephensj1 stephensj1 is offline
New Player
 
Join Date: Aug 2011
Posts: 2
Default Tutorial Videos stuttering

My tutorial videos are stuttering. Which codecs are in use? I want to try ffdshow or atleast make sure they are current. I could totally be way off base as to this being the issue, but I want to check this first, thanks.

Edit: It's just the tutorial videos that are stuttering, everything else is processing fine.

Last edited by stephensj1; 08-23-2011 at 07:46 AM. Reason: More info
Reply With Quote
  #8  
Old 08-23-2011, 08:08 AM
jaycw2309's Avatar
jaycw2309 jaycw2309 is offline
Inside Man
Eidos Official
 
Join Date: Apr 1998
Location: Wimbledon
Posts: 3,667
Default

Quote:
Originally Posted by stephensj1 View Post
My tutorial videos are stuttering. Which codecs are in use? I want to try ffdshow or atleast make sure they are current. I could totally be way off base as to this being the issue, but I want to check this first, thanks.

Edit: It's just the tutorial videos that are stuttering, everything else is processing fine.
Once in game everything is handled by the `game` so to speak.. if the cutscenes play okay then theres nothing wrong with the playback so to speak..
__________________
http://www.imdb.com/name/nm1255523/ <-thas me hehe
Twitter: @jaywalker2309
- My opinion is my own and not that of the company.
Reply With Quote
  #9  
Old 08-23-2011, 08:09 AM
jaycw2309's Avatar
jaycw2309 jaycw2309 is offline
Inside Man
Eidos Official
 
Join Date: Apr 1998
Location: Wimbledon
Posts: 3,667
Default

Glad to hear the problem seems to be resolved
__________________
http://www.imdb.com/name/nm1255523/ <-thas me hehe
Twitter: @jaywalker2309
- My opinion is my own and not that of the company.
Reply With Quote
  #10  
Old 08-23-2011, 08:10 AM
stephensj1 stephensj1 is offline
New Player
 
Join Date: Aug 2011
Posts: 2
Default

Thanks for the quick reply. I'll make due.
Reply With Quote
  #11  
Old 08-23-2011, 08:50 AM
BobTheSpy BobTheSpy is offline
New Player
 
Join Date: Aug 2011
Posts: 12
Default Low FPS when looking at a new area

This is going to sound kind of weird - but I've never had a problem quite like this. Basically, if I'm in an area I've already seen, my FPS will be all find and dandy. But if I turn to look at an area I haven't seen yet, there's an FPS drop. Anyone know what I could do to make this stop happening?
Reply With Quote
  #12  
Old 08-23-2011, 09:03 AM
xfullboost xfullboost is offline
New Player
 
Join Date: Aug 2011
Location: Maryland, USA
Posts: 19
Default

I was literally about to post the exact same question when I saw your thread! I am having the same issue as you. I would suggest posting more information about your setup so others can more easily assist us. Such as steam or retail versions? what operating system and your computer specs.

Problem: Poor game performance when entering new areas in-game. 60fps to 35fps with a noticeable (and irritating) micro stutter. I tried HR on both my SSD and HDD with same performance. I tried two other games to see if my system was doing this to all applications. The Witcher 2 ran fine when running into a new city or town, and Arma 2 ran fine when zooming in with a sniper rifle.

Deus Ex Human Revolution Augmented Edition Steam edition

System
Windows 7 Ultimate 64bit
AMD Phenom II x6 1090T (4ghz 250x16)
Asus Radeon HD 6970 (2 in crossfire)
Asus Crosshair IV Formula
OCZ Vertex 3 MAXIOPS 120gb SSD
Corsair Dominator GT DDR3 8GB
Creative Soundblaster X-Fi MB
Full water cooling, all temps never exceed 45c.

Last edited by xfullboost; 08-23-2011 at 11:18 AM. Reason: system specs updated
Reply With Quote
  #13  
Old 08-23-2011, 11:20 AM
xfullboost xfullboost is offline
New Player
 
Join Date: Aug 2011
Location: Maryland, USA
Posts: 19
Default

I am getting rather piss poor performance in city hubs. When moving from one end of the city to the other, I experience 4 hiccups (or slow downs or fps drops) I have experienced this before in games. The game is loading new textures, and its doing so badly. My fps is not what is taking the hit, its the data loading in the first place. And let me remind you, I am on a solid-state drive with over 500mb/s read/write rate. What gives?

Last edited by xfullboost; 08-24-2011 at 05:43 AM.
Reply With Quote
  #14  
Old 08-23-2011, 11:23 AM
[FGS]Shadowrunner's Avatar
[FGS]Shadowrunner [FGS]Shadowrunner is offline
Protagonist
 
Join Date: Jun 2008
Location: London
Posts: 1,156
Default

Quote:
I've never had a problem quite like this
Very much so in Deus Ex 1. It's to be expected that when suddenly viewing a large detailed area for the first time, there will be an initial fps drop.
__________________
signature image
Reply With Quote
  #15  
Old 08-23-2011, 12:20 PM
BobTheSpy BobTheSpy is offline
New Player
 
Join Date: Aug 2011
Posts: 12
Default

My Specs are:
GTX 560 ti
Phenom II X4 955 3.2 Ghz Quad-core processor
4 GB RAM
Windows 7 Ultimate
Reply With Quote
  #16  
Old 08-23-2011, 03:37 PM
BobTheSpy BobTheSpy is offline
New Player
 
Join Date: Aug 2011
Posts: 12
Default

Bump, anyone else have this issue? It seems to really only affect the City Hubs - or is this normal and I should quit *ing?
Reply With Quote
  #17  
Old 08-23-2011, 06:00 PM
ArnoKalavent ArnoKalavent is offline
New Player
 
Join Date: Aug 2011
Posts: 5
Default STUTTERING & LAG - All Issues - Audio/Video

I'm running my game at max settings and the actual gameplay is just fine. All of the pre-recorded videos stutter making it very difficult to figure out what's going on in them.
Reply With Quote
  #18  
Old 08-23-2011, 07:32 PM
ghost654 ghost654 is offline
Registered User
 
Join Date: Aug 2011
Posts: 1
Default lag / frameskipping

My deus exs frame rate seems pretty good and smooth but occasionally it feels like it skips a frame or lags. At first I thought that my old video card finally hit something it couldn't play well (geforce 8800gt). But I tried on my friends new i5-2500k, geforce 570 computer and it had the same issue. It ran smooth overall except for that occasional lag, so i dont think it is the hardware causing it.

I can really see it happen the most when walking diagonally it seems. and sometimes when just turning while walking straight.
Reply With Quote
  #19  
Old 08-23-2011, 10:13 PM
rokstrombo rokstrombo is offline
Gamer
 
Join Date: Feb 2008
Posts: 512
Default

It might be helpful to Eidos Montreal if you were to post your system specifications (including the operating system, audio interface and speaker/headset setup used).

You could try the following workaround to help troubleshoot this problem:
  • Start > Run.
  • Type 'dxdiag' and press Enter.
  • Click on the 'Sound' tab (there may be several if you have multiple audio interfaces installed).
  • Under 'DirectX Features', note the relative position of the 'Hardware Sound Acceleration Level' slider. Next, move the slider to the leftmost option 'No Acceleration'. Click 'Exit'.
  • Launch Human Revolution and replay cutscenes. If the stuttering is fixed, exit Human Revolution and try re-opening dxdiag and moving the slider further to the right to see if the stuttering recurs.

Note that changing the Hardware Sound Acceleration Level may introduce problems in other areas, so if successful remember to return the slider to it's original value when you finish playing.
Reply With Quote
  #20  
Old 08-23-2011, 10:51 PM
Senpai C Senpai C is offline
Registered User
 
Join Date: Aug 2011
Posts: 1
Default

I think that might be a direct x issue. I have a problem that sounds just like yours on my ATI Radeon HD 4870. My brother has one that's a bit more powerful but with direct x11 and turning dx11 on fixes it. When it's turned off on his pc it has the same issue that mine does. I've already experimented around with all of the other settings so I'm fairly certain it's a direct x issue.
Reply With Quote
  #21  
Old 08-24-2011, 12:02 AM
Johnnytd Johnnytd is offline
Registered User
 
Join Date: Aug 2011
Posts: 1
Default Same problem

I am having the exact same problem and it is frustrating that this seems to be an isolated issue. Is anyone else experiencing this and have a fix? It would be greatly appreciated
Reply With Quote
  #22  
Old 08-24-2011, 01:17 AM
Tommando Tommando is offline
Gamer
 
Join Date: Aug 2011
Posts: 31
Default

I'm also having a problem with framerate drops, on an HD 4870. The framerate tends to be rather choppy when coming out of a loading screen, but I don't mind that too much as it smooths out after 20 seconds or so. Much more bothersome(and something I didn't notice until I got out onto the streets for the first time)is a tendency for the framerate to drop dramatically when turning a corner or otherwise stepping into a new area.

I can understand how generating that new stuff as it comes into view might increase the strain on resources and thus cut into performance, but I don't see why that should be happening here when I've played plenty of other games with much larger and and more active environments without having the framerate ever take a noticeable hit.

I've played around with various settings in-game and in CCC but nothing seems to work. Hopefully a patch or fix will come along to make the framerate more consistent. I wouldn't even mind capping the FPS at 30 if that would guarantee it stayed at 30 constantly and didn't stutter.
Reply With Quote
  #23  
Old 08-24-2011, 01:30 AM
Darktronik Darktronik is offline
New Player
 
Join Date: Aug 2011
Posts: 11
Default

Ive got the frameskipping too.
Reply With Quote
  #24  
Old 08-24-2011, 02:01 AM
bughole5 bughole5 is offline
Gamer
 
Join Date: Aug 2009
Posts: 73
Default

same here, is it intentional?
Reply With Quote
  #25  
Old 08-24-2011, 02:20 AM
xfullboost xfullboost is offline
New Player
 
Join Date: Aug 2011
Location: Maryland, USA
Posts: 19
Default

I'm still getting a bad stutter in the city hubs. not to mention really long loading times for the levels themselves. this game feels poorly optimized, or am i the only one? still, there have been much worse games and im not too bothered by it. im still enjoying my time in-game very much so.
Reply With Quote
Reply

Bookmarks

Tags
amd, audio, deus ex stutter fps drop, performance, single core, stutter, stuttering

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 09:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.