Results 1 to 6 of 6

Thread: "View First Unread" doesn't appear to always work

  1. #1
    Join Date
    May 2009
    Location
    Austin, TX
    Posts
    84

    Default "View First Unread" doesn't appear to always work

    There doesn't seem to be a forum for forum difficulties and this appears to be the best place.

    The "View First Unread" feature seems to mark threads or posts as read even when I haven't read them. I have subscribed to a bunch of threads in the Thief 4 forum and I will often go to my User CP to view which ones have updates. Sometimes I'll open my User CP, see a whole bunch of threads with new content (and the down arrow to jump to new posts) and I'll read a couple of them and go away for a while. When I come back, I am often finding that a lot of those threads (but not all of them) that had posts I hadn't read are no longer showing as as having unread posts and the "View First Unread" button doesn't appear when I visit them. I have been unable to discern a pattern so far.

    I know for sure there is a bug since I made a post in http://forums.eidosgames.com/showthread.php?t=88598 a couple of days ago and definitely hadn't read it since, but when I went to my subscription list, I could see there was a new post but it wasn't marked unread. I went to the thread and again it didn't have the unread button on it.

    This is making it hard to keep track of the threads I'm interested in and when they get new posts.

    Running: FF 3.0.10 on Windows XP
    Sign the petition to release the Thief I and II engine source code: http://www.petitiononline.com/ThiefSrc

  2. #2
    Join Date
    Sep 2008
    Location
    ~Lara's Rainbow Rock
    Posts
    3,036

    Default

    I believe when you go to your User CP and don't click/read some threads, they will go of the list next time you want to check your subscribed threads. I believe it's because the forum thinks that you don't want to read those threads anymore or something Oo I'm not sure. I'm having a bit trouble with it as well.

  3. #3
    Join Date
    Jan 1970
    Location
    Land of the wurst.
    Posts
    2,402

    Default

    Quote Originally Posted by TazmanianD View Post
    There doesn't seem to be a forum for forum difficulties and this appears to be the best place.
    This is the right place so thanks for mentioning it here.

    Hmm, let me have a look into it and I'll get back to you.


    Thanks again for flagging it.
    "......It reminds me of Beethoven..... can you hear it?"

  4. #4
    Join Date
    May 2009
    Location
    Austin, TX
    Posts
    84

    Default

    I've several cases for you to look at. I've been intentionally not reading any of the messages on these forums to see if this problem appears again. I have not read any messages that are on my subscription list since the previous message posted in this thread.

    If I go to my subscription list in my User CP, I can see four threads that have had messages posted to them today, but only two of them have the "Go to first new post" icon.

    One of those threads is here: http://forums.eidosgames.com/showthread.php?t=88631

    I have not opened or read this thread today or the message that I can see from my subscription list that was posted today.

    Another thread with a new post: http://forums.eidosgames.com/showthread.php?t=88594
    Sign the petition to release the Thief I and II engine source code: http://www.petitiononline.com/ThiefSrc

  5. #5
    Join Date
    May 2009
    Location
    Austin, TX
    Posts
    84

    Default

    I think I know what's happening. It seems that simply opening the User CP marks all the threads as having been read. However, it does not do so right away. If I close my browser and re-open it, the threads are still marked as unread but if I return to the site a few hours later, all the threads are marked as read.

    As a web developer myself, I'm guessing that opening the User CP marks the threads as read, but they remain unread in a memory cache within the servlet session and they contain to show as unread until I actually read them (which marks them read in the session) or the session expires. As a test, I tried deleting my cookies and logged back into your website and sure enough, all the threads were immediately marked as read without me having to wait after a period of time for that to happen. I don't know why reading the User CP would mark the threads read in your database, but not in the session.

    I'm not sure if this is intentional behavior or not, but I find it very unpleasant and consider it a bug. Threads should be marked as read when I read them or explicitly mark them as read.
    Sign the petition to release the Thief I and II engine source code: http://www.petitiononline.com/ThiefSrc

  6. #6
    Join Date
    May 2009
    Location
    Austin, TX
    Posts
    84

    Default

    Quote Originally Posted by Keir View Post
    Hmm, let me have a look into it and I'll get back to you.
    Had you had a chance to read my last posts and look into this further? It's been a couple of weeks.
    Sign the petition to release the Thief I and II engine source code: http://www.petitiononline.com/ThiefSrc

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •